01 Jul

MPLS workshop #5 – CE-PE connection using EIGRP

Last protocol I’ll be focusing on for CE-PE connection is EIGRP. As in OSPF redistributing routes from EIGRP to BGP and back to EIGRP makes them external from routing protocol perspective. Using BGP extended communities many characteristics including AS number, tags or metric components are passed between PE routers and allows reconstruction of prefix. If the EIGRP route is internal it’s redistributed back as internal if AS numbers on remote PE router matches the source one (it’s encoded using external community). Otherwise it’s redistributed as EIGRP external.

Basic configuration is quite simple and similar to OSPF configuration described before. For purpose of this part of lab Ethernet connection between R2 and R3 is disabled and Serial connection is introduced using Serial2/3 interface configured. This link will be VRF_C member.

Configuration of CE routers is as simple as standard EIGRP process

R2

router eigrp 65002
 network 10.0.23.0 0.0.0.255
 no auto-summary

R10

router eigrp 65002
 network 10.0.0.10 0.0.0.0
 network 10.0.50.0 0.0.0.255
 no auto-summary

We advertise loopback only on R10. Now the PE part. As in OSPF we have to remember to redistribute between BGP and EIGRP. The customer EIGRP AS number is defined for particular VRF under address-family section.

R3

router eigrp 65111
 !
 address-family ipv4 vrf VRF_C autonomous-system 65002
  redistribute bgp 65111 metric 10000000 0 255 1 1500
  network 10.0.23.0 0.0.0.255
  no auto-summary
 exit-address-family
 no auto-summary
!
router bgp 65111
 address-family ipv4 vrf VRF_C
  no synchronization
  redistribute eigrp 65002
 exit-address-family

R5

router eigrp 65111
 !
 address-family ipv4 vrf VRF_C autonomous-system 65002
  redistribute bgp 65111 metric 10000000 0 255 1 1500
  network 10.0.50.0 0.0.0.255
  no auto-summary
 exit-address-family
 no auto-summary
!
router bgp 65111
!
 address-family ipv4 vrf VRF_C
  no synchronization
  redistribute eigrp 65002
 exit-address-family

First verification is if R2 is receiving prefixes advertised by R10

R2#show ip route eigrp 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D        10.0.0.10/32 [90/2323456] via 10.0.23.3, 00:05:54, Serial2/3
D        10.0.50.0/24 [90/2195456] via 10.0.23.3, 00:05:54, Serial2/3

Same as for OSPF we can check how EIGRP prefix attributes are converted into BGP extended community

R5#show ip bgp vpnv4 vrf VRF_C 10.0.0.10/32  
BGP routing table entry for 65002:1:10.0.0.10/32, version 66
Paths: (1 available, best #1, table VRF_C)
  Advertised to update-groups:
     1         
  Local
    10.0.50.10 from 0.0.0.0 (10.0.0.5)
      Origin incomplete, metric 409600, localpref 100, weight 32768, valid, sourced, best
      Extended Community: RT:65002:1 Cost:pre-bestpath:128:409600 
        0x8800:32768:0 0x8801:65002:153600 0x8802:65281:256000 
        0x8803:65281:1500
      mpls labels in/out 23/nolabel

One thought on “MPLS workshop #5 – CE-PE connection using EIGRP

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: